 FAQ: Как вычислить базовую станцию (БС) сотового оператора стандарта GSM?

FAQ: Как вычислить базовую станцию (БС) сотового оператора стандарта GSM?

БС BeeLine GSM около ж/д станции Сергиев Посад

В порядке духовного наставления хочу выразить глубокое сожаление, если этот документ сделает Вас заядлым нетмониторщиком, запускающим в телефоне соответствующие тесты хотя бы раз в день. Постарайтесь не вовлекаться в эту сферу. А если не удастся, то не распространяйте этот опыт на всех желающих. Пусть чтение подобной нотации новому ученику станет для Вас нормой, если ЭТОМУ вы научились у меня. И пусть это не будет никому во вред.

Итак, начнем.
Способов сделать ЭТО много. Все зависит от Вашей опытности. Порой вовсе не обязательно даже иметь телефон при себе. Однако, для максимальной производительности в идеале надо располагать следующими средствами
  1. Сотовым телефоном.
  2. Включенным в нем NetMonitor'ом.
  3. Сим-картой соотвествующего оператора.
  4. Хорошим зрением или подзорной трубой
  5. Образами внешнего вида антенн соответствующего оператора

Для дальнейшего чтения этого документа Вам надо понять, что представляет собой NetMonitor Вашего телефона. Если же NetMonitor недоступен вам по той или иной причине, переходите сразу сюда. Я не хочу подробно останавливаться на том, как им пользоваться, т.к. это несколько отдельная тема, да и владею я хорошо таковым лишь в телефонах Nokia и Siemens. Это можно сделать, например по ссылке на сайт белорусских нетмониторщиков. Там же можно узнать, как активировать этот режим в той или иной модели.

1. НетМониторинг и способы обнаружения БС с его помощью.
    Если вы уже знаете, что такое, и как достоверно получить
  • Уровень сигнала (RX)
  • Номер канала (CH)
  • Идентификатор соты (CID)
  • Тайм-адванс (TA)
  • Отличаете каналы 900 от 1800 и от EGSM
  • Понимаете, что такое сектор БС

то можно приступать к делу. Для простоты рассуждений RX мы измеряем по убывающей логарифмической шкале (типичной для Siemens & Nokia), где допустимому уровню сигнала соответсвуют значения ниже -110 и более (вплоть до 0). Чтобы избежать "модульных" разночтений с понятиями "больше"-"меньше", буду пользоваться категориями "лучше"-"хуже". Для примера: RX=-50 это лучше чем RX=-70.
Под обнаружением БС мы будем понимать осознание факта что мы находимся близко от нее. Иначе мы ее не найдем. Вообще говоря, "близость" в нашем случае будет радиофизическая (еще бы - ведь с радиосредством дело имеем!), то есть относительная. Хотя если вспомнить что зрение - тоже к радиофизике отношение имеет, то ничего пугающего в этом факте, в т.ч. для непросвещенных, в итоге не будет. Почему, надеюсь, догадаетесь чуть позже.

    Итак, причины заподозрить близость БС:
  • Сигнал лучше -60
  • Последняя цифра (в десятичной записи) номера CID изменилась, а остальные - нет
  • TA не более 3
Теперь подробнее по пунктам.

Если сигнал очень хороший, это свидетельствует о том, что препятствий на его пути очень мало. Это еще не значит, что до БС - рукой подать. Но уже что-то. Особенно это характерно для каналов GSM-1800 которые в пространстве затухают быстрее, чем GSM-900. Цифра -60 выведена опытным путем. Если сигнал лучше -50, то это гарантия, что БС либо в прямой видимости, либо если и не видна, то очень близко (например, за стенкой). Заметьте, что обратные рассуждения не верны. Даже стоя под антенной словить можно что угодно - это как телефон держать (например зажать в руке :).
Далее. Обычно секторы базовой станции нумеруют как номер БС*10 + номер сектора в БС. Как правило, на удаленном расстоянии от БС ее сектора не накладываются - в силу диаграмм направленности секторов и их пространственной ориентации. Однако, не надо забывать, что покрытие 900 и 1800 - в основном - существуют как дополняющие друг друга слои. Так что критерий смены последней цифры надо применять только в пределах одного диапазона. Это точно можно отследить по номерам контрольных каналов и достаточно точно по самОй последней цифре. Дело в том, что для порядка операторы секторы одного диапазона обычно нумеруют теми же цифрами. Правда, у всех по разному.

Примеры. Информация подлежит уточнению.
Номер сектора | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
BeeLine GSM | 1800 | 1800 | 1800 | 900 | 900 | 900
MTS RUS;Velcom By | 900 | 900 | 900 | 1800 | 1800 | 1800
MegaFon-MSK | 900/EGSM | 900/EGSM | 900/EGSM | 900/EGSM | 1800 | 1800 | 1800 | 1800

Есть еще одна тонкость. Мегафон-Москва частенько на все физические сектора (т.е. разные антенны) одной БС ставит одинаковые номера. Это затрудняет идентификацию - бегаешь вокруг базы, сигнал экстремальный, а номер сектора не меняется. Будьте к этому готовы :)
В случае с Тайм-Адвансом все как с уровнем сигнала, только еще очевиднее. Этот параметр прямо пропорционален оптическому пути сигнала, так что если он менее 3, то значит что расстояние, пройденное сигналом - не более 2 километров. Конечно, порой представить возможные переотражения сигнала в городских условиях трудно, так что этот параметр порой даже может портить картину. Ну а если он равен 0, то вопросов нет :) P.S. Не забудьте обменяться данными с сетью, например сделать звонок, дабы значение TA было актуальным.

2. Если у Вас нет нужных сим-карт (чтобы осуществить звонок в нужной сети)

В телефонах Siemens есть возможность принудительно выбрать сеть (если автопоиск отключен). Для обновления параметров можно попробовать сделать звонок на несуществующий номер. Только не звоните в 112 - уважайте время Службы Спасения.
В телефонах Nokia если воспользоваться 19 тестом, можно прослушивать все каналы всех операторов.

3. Теперь к визуальным наблюдениям. А также если у Вас нет телефона или нетмонитора в нем

Вы должны знать, как выглядят антенны базовых станций и где их размещают.
Вскоре я постараюсь дополнить руководство хорошими иллюстрациями, но пока обойдусь словесными описаниями. В подавляющем большистве случаев антенны используются секторные, с углом "освешения" до 120 градусов в горизонтальной плоскости. Поэтому и форма их такая, чтобы излучать только в одном направлении. Выглядят они как вытянутые параллелепипеды светлых цветов. Ширина в основном не более 20 см., толщина не более нескольких см. Различается в основном длина, которая может быть вплоть до 2.5 м. Я использую пришедшее к нам из Белоруссии название "огурец"
Встречаются пико-соты и репитеры, к сожалению эти штуки несколько портят картину. Во-первых, они довольно редко ставятся прямо возле БС и Тайм-адванс даже в непосредственной близости от них может быть довольно большим. Во-вторых, их обнаружение куда более трудное из-за их малых размеров и разнообразия геометрических форм. В Белоруссии есть прецеденты когда неопытные следопыты фотографировали неактивные светильники аварийного освещения в метро и искренне радовались, будто нашли пико-соту. В-третьих, картины уровня радиосигнала отличаются.
Операторам свойственно использовать антенны одних и тех же производителей и типов, но для их различения нужен большой опыт. Жестких закономерностей не существует, но отдельные признаки выделить можно. Например, в Москве и Минске пока не было замечено антенн Allgon ни у кого кроме МТС. А эти антенны характерны своим синеньким логотипом прямо на панелях. А вот антенны Kathrein испольуются чаще или реже, но всеми и во всех регионах. Более подброно - позже

Размещение различается весьма и весьма.
    Закономерности можно разделить по признакам
  • Высота размещения
  • Виды сооружений/зданий/предприятий
  • Виды мачт
  • Места крепления
  • Углы наклона
  • Количество антенн
Несколько наблюдений по пунктам. Но это лишь обобщения, а не строгие правила.
На негородских территориях, очевидно, для максимальной площади покрытия все стремятся водрузить антенны повыше. А вот в Москве, например, ситуация иная. Билайн любит антенны на очень высоких зданиях, но крайне редко использует дополнительные мачты. Мегафон ставит как можно ниже, в основном уровень - не выше этажа пятого. МТС любит дополнительные мачты и рамы даже на высоких зданиях, МФ тоже не брезгует, но реже - зачем мачта если надо ставить низко. Мачты Мегафона как правило если невысокие, то серые.
Билайн издавна не брезговал жилыми домами, а мегафон ставит в основном на низких зданиях, типа магазинов. МТС частенько встречается на АТСках, а Билайн очень любит кирпичные трубы.
Билайну свойственны большие углы наклона для антенн 900 МГц, а 1800 не наклоняются вообще. Мегафон зачастую направляет антенны вверх.
Если антенн 4 штуки только на один сектор, то это скорее всего Билайн. Билайн вооще не так часто использует совмещенные приемо-передатчики, хотя бывает. То есть либо одна на сектор, либо все 4. Также почти никогда не бывает 4 секторов у кого-то кроме Мегафона.

И, наконец, даже в плотной застройке всегда можно делать исключения для гипотез, исходя из имеющихся знаний. Т.е. одному оператору нет смысла ставить 2 БС на расстоянии 50 м друг от друга. Это слишком накладно. Единственное, о чем не стоит забывать, что кроме GSM существуют и другие стандарты.

4. Базы данных по антеннам

В связи с ростом движения следопытов-нетмониторщиков все в большем количестве регионов появляются интернет-сайты с данными по расположению антенн. К слову, если Вы хотите сделать что-то подобное, сначала посмотрите - не делаете ли Вы повторную работу. Наилучшие работы из околославянских замечены в Белоруссии,Одессе и Санкт-Петербурге
Прочие ссылки

Итог

Итак, комбинируя эти методы и знания, Вы в 95% случаев сможете найти и идентифицировать БС. Увы, в последнее время в крупных мегаполисах становится все труднее это сделать. Случаются ситуации, что в любом доступном Вам месте Вы видите станции нескольких операторов, не отличающихся ни внешне, ни по картине сигнала. И для того, чтобы определить что-либо достоверно, придется делать уже подозрительные действия, вроде ненужных вопросов работникам учреждений или подглядываний в подзорную трубу.